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BASICS IN COMPUTERS
Introduction

▪▪ Computer is an electronic device, which manipulates and stores data and informa-
tion through commands or program codes. The computer that was designed in the 
year 1946 was equivalent to the size of a huge class room. When compared to the 
computers of earlier stages with today, the size is minimized but the efficiency and 
speed has increased infinitely. Not only the speed but also it can be used according 
to our convenience as desktops, laptops and mobile devices.  The size and shape of 
the computer has been modified on the basis of our need. Generally, the computer 
operates by the exchange of commands between the hardware and software. Hard-
ware can be touched and felt, but the software cannot be.

History of Computer
▪▪ Now a days, we can find computer in many forms like desktop, laptop, palmtop, 
tablet etc.  This kind of transformation in data handling and processing has hap-
pened over a long period of time.  Let us know about the advancement of computer 
here.

▪▪ Around 2000 years ago, the people of China used Abacus.  This was considered 
as the most basic model of a computer.  Nineteenth century was considered as the 
birth of the computer when Charles Babbage designed the basic construction of 
a computer. ENIAC, which was used by the American Military in 1946 to predict 
the trajectory of artillery shells was recognized as the world’s first general purpose 
computer. Lady Augusta Ada Lovelace was honored as the first programmer as she 
gave the first programming to do arithmetic operations.

Generations of computer
▪▪ The history of computer has been classified into many stages. The main difference 
between the generations is the speed and efficiency of the computer.  On the basis of 
performance and speed, the generations of the computer was categorised.

Information Technology
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Period Generation Digital devices

1940-1956 I Generation Vacuum tubes

1956-1963 II Generation Transistor

1964-1971 III Generation Integrated circuits

1972-2010 IV Generation Micro processors

After 2010 V Generation Artificial Intelligence

Data
▪▪ Data is the set of values of qualitative and quantitative variables. The data that is 
fed to the computer can be text, number or statistics. These data stored in computer 
memory cannot be used directly. It has to be processed.

Data processing
▪▪ The data processing in a computer is collecting data and converting it into informa-
tion according to our needs and requirements. 

Data processing has six steps. They are: 
▪	 Collection 			   ▪  Storage 
▪	 Sorting 				    ▪  Processing 
▪	 Analysis 				    ▪  Presentation and conclusions

PARTS OF COMPUTER

Introduction
In this Modern World computer eases the eff ort and speeds up the processes to a great 
extent. Now-a-days the usage of computer plays an important role in every walk of life.  So, 
it is apt time to learn about computers. To start, it is necessary to note that there are three key 
units in the computer. Understanding of this three units will make us to operate a computer 
in ease. In this section, let us learn what are the three units and what are the functions of each 
of these units.

Three parts of the computer are: 

▪▪  Input Unit 

▪▪ Central Processing Unit (CPU) 

▪▪ Output Unit
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Input Unit: The input unit helps to send the data and commands for the processing. The 
devices that are used to enter data are called input devices. Keyboard, Mouse, Scanner, Bar-
code reader, Microphone-Mic., Web camera, Light Pen are some of the input devices. 

Keyboard: Keyboard and mouse are the important input units. Keyboard plays an im-
portant role in a computer as an input device. Numbers and alphabet play a role of Data in 
computer. Keyboard helps to enter data. Keyboard has two types of keys, namely number 
keys and alphabet keys. The keys with numbers are called number keys and the keys with 
letters are called alphabet keys.

Mouse: Mouse is an essential part of the computer. Mouse has two buttons and a scroll ball 
in the middle. The mouse is used to move the pointer on a computer screen. Right button is 
used to select files and to open the folder. Left button is used to carryout corrections in the 
file. The page on the monitor can be moved up and down using the scroll ball.

Central Processing Unit (CPU): CPU is the brain of the Computer. The data is pro-
cessed in the CPU. The CPU has namely three parts.

1. Memory Unit 

2. Arithmetic Logic Unit (ALU) 

3. Control Unit 

Memory Unit 
▪▪ The memory unit in the computer saves all data and information temporarily. The 
data is measured in units which is called as Bit.  A Bit has a single binary value ei-
ther 0 or 1. 

▪▪ We can classify memory unit into two types namely primary and secondary mem-
ory.  

▪▪ Memory can be expanded externally with the help of Compact Disk (CD), Pendrive, 
etc. 

▪▪ Arithmetic Logic Unit Arithmetic and Logic unit performs all arithmetic computa-
tions like addition, subtraction, multiplication and division. 

Control Unit: The control unit controls the functions of all parts of the computer.

Output Unit 
▪▪ The Output unit converts the command received by the computer in the form of 
binary signals into easily understandable characters. 

▪▪ Monitor, printer, speaker, scanner are some of the output devices. Of the various 
output devices, monitor is the important output device because it is the link to the 
computer. Monitor screen looks like TV screen. 
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▪▪ The input data in the form of Alphabets, Numbers, Pictures or Cartoons and Videos 
will be displayed on a monitor. 

There are two types of monitor namely, 

1. Cathode Ray Tube monitors (CRT) 

2. Thin Film Transistor Monitors (TFT) 
Now a days computer system has TFT monitor as they occupy less space and emit less heat 
than CRT monitors.

Classification of Computer: Computers can be classified as below based on their de-
sign, shape, speed,  efficiency, working of the memory unit and their applications.

▪▪ Mainframe Computer 

▪▪ Mini Computer 

▪▪ Micro or personal computer

▪▪ Super computer

Personal computer: Personal computer comes under the microcomputer. Based on the 
memory and efficiency in PC they can be classified as
	 1.Desktop           2. Laptop           3.Tablet

Connecting the computer: Various parts of the computer are linked through connect-
ing cables. We call computer as system as it is connected with one another. There are many 
cables used to connect these parts.  These cables are called as connecting cables.  These cables 
are found in different sizes. Each cable has its own specific uses.

TYPES OF CABLES

Different types of cables are
Video Graphics Array (VGA), High Definition Multimedia Interface (HDMI), Universal 
Serial Bus (USB), Data cable, Power Cord, Mic cable, Ethernet cable

▪▪ VGA Cable: It is used to connect the computer monitor with the CPU. 

▪▪ USB cable /cord: Devices like Printer, Pendrive, Scanner, Mouse, Keyboard, web 
camera, and Mobile phone devices are connected with the computer using USB cord 
or cable.

▪▪ HDMI Cable: HDMI cable transmits high quality and high bandwidth streams of 
audio and video. It connects monitor, projector with the computer. 

▪▪ Data Cable: Data cable transmits data and it is used to connect tablet, mobile phones 
to the CPU for data transfer. 

▪▪ Audio jack: The audio jack is used to connect the speaker to the computer.
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▪▪ Power cord: Power cord temporarily connects an appliance to the main electricity 
supply. 

▪▪ Mic cable: To connect the Mic to the CPU, Mic wire/cord is used.
▪▪ Ethernet: Ethernet cable helps to establish internet connectivity.

Wireless Connections:
Bluetooth, Wi-Fi are used to connect to internet without using any connecting cables / 
devices. 

▪▪ Bluetooth Mouse, Keyboard can be connected to the computer using the Bluetooth. 
Using Bluetooth the data can be shared with nearby devices.

▪▪ Wi-Fi Net connectivity can be obtained using the Wi-Fi without any connecting ca-
bles. Any data from anywhere can be shared using Wi-Fi.

HARDWARE AND SOFTWARE

Introduction
▪▪ Computer is a device comprising both hardware and soft ware. The functions of 
hardware and soft ware combines together to make the Computer functional. A 
hardware device helps to enter input information. 

▪▪ The soft ware processes the input data and gives the output in the monitor, a hard-
ware device. Thus, a computer is like a human body, where human body is the 
hardware and soul is the soft ware.

Hardware: Hardware is the parts of a computer which we can touch and feel. Hardware 
includes Input and Output devices, Cabinet, Hard Disk, Mother Board, SMPS, CPU, RAM, 
CD Drive and Graphics Card.

Software: Hardware is lifeless without software in a computer.  Software are programmed 
and coded applications to process the input information. The software processes the data 
by converting the input information into coding or programmed language.  Touching and 
feeling the software is not possible but we can see the functions of the software in the form 
of output 

Types of Software
The software is divided into two types based on the process. 

▪▪ They are: 1. System soft ware (Operating System) 2. Application soft ware System 
software :

▪▪ System software (Operating system) is a software that makes the hardware devices 
process the data fed by the user and to display the result on the output devices like 
Monitor. Without the operating system, computer cannot function on its own. Some 
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of the popular operating system are Linux, Windows, Mac, Android etc. 

1. Application Software 
▪▪ Application software is a program or a group of programs designed for the benefit 
of end user to work on computer. The application programs can be installed in the 
hard disk for the usage on a particular computer. This type of application program 
completes one or more than one works of the end user. 

▪▪ The following are the examples of application program: Video player, Audio player, 
Word processing soft ware, Drawing tools, Editing soft ware, etc.

2. System and Application Software types
The operating system and application software are available in two forms. They are: 

1. Free and Open source 
2. Paid and Proprietary  Software

Free and Open source 
▪▪ Free and open software is available at free of cost and can be shared to many end 
users. Free software is editable and customizable by the user and this leads to upda-
tion or development of new software. 

▪▪ Examples of Free and Open source software are: LINUX, Open  office, Geogebra etc.

 Paid and Proprietary Software 
▪▪ These are softwares that need a license to use it. They have to be paid for using ei-
ther permanently or temporarily. The license of the software would not be provided 
unless it is purchased. 

▪▪ Similarly the end users are legally prohibited to steal the software program or to use 
the pirated version of the Paid and Proprietary Software. 

▪▪ Some of the examples of Paid and Proprietary Software are: Windows, Microsoft 
office, Adobe Photoshop, etc.



9

General Aptitude & Mental Ability

VISUAL COMMUNICATION

Introduction 
Libre Office is a powerful and free office suite, used by millions of people around the world. 
Its clean interface and feature-rich tools help you unleash your creativity and enhance your 
productivity. In this chapter, you will learn to use the software Libre Office.

Libre Office Components
▪▪ Text Document Writer (word processor) is a feature rich tool for creating letters, 
books, reports, newsletters, brochures, and other documents. 

▪▪ Calc (spreadsheet) Calc has all of the advanced analysis, charting, and decision mak-
ing features expected from a high-end spreadsheet. It includes over 300 functions 
for financial, statistical, and mathematical operations, among others. 

▪▪ Impress (Presentations) Impress provides all the common multimedia presentation 
tools, such as special effects, animation, and drawing tools.

▪▪ Drawing (Vector graphics) Draw is a vector drawing tool that can produce every-
thing from simple diagrams or flowcharts to 3D artwork.

▪▪ Base (Database) Base provides tools for day-to-day database work within a simple 
interface. It can create and edit forms, reports, queries, tables, views, and relations, 
so that managing a relational database is much the same as in other popular data-
base applications.

▪▪ Math (Formula editor) Math is the Libre Office formula or equation editor. You can 
use it to create complex equations that include symbols or characters not available 
in standard font sets.

Text Document:  In this section, we will discuss about the word processing. You can use 
it to type letters, reports and other documents. You use the Word window to interact with 
Text Document.

Managing Documents: There are several ways to create a new document, open existing 
documents and save documents in Word.

Create a New Document
To create a new document, do any one of the following methods: 

1. Click the New Document button on the menu bar. 
2. Choose File→New command from the menu bar. 
3. Press CTRL+N keys on the keyboard. 
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Open an Existing Document
To open an existing document, do any one of the following methods: 
1. Click the Open File button on the menu bar. 
2.  Choose File→Open command from the menu bar. 
3. P ress CTRL+O keys on the keyboard. 
Each of the above method will show the Open dialog box. Choose the fi le and click the Open 
button. 

Save a New/Existing Document 
To save a new/existing document that is opened, follow any one of the following methods: 

1. Click the Save button on the menu bar. 
2.  Select File→Save commands from the menu bar. 
3. Press CTRL+S keys on the keyboard.

If the document is already named and saved earlier, it will simply save the document. 
On the other hand, if the file is a new document then it will prompt you by opening ‘Save As’ 
dialog box. Select the folder where you want to place your document. Type the name of the 
document in File Name and then click OK. You can also save a new document by choosing 
File→Save As commands on the menu bar and then selecting the above actions in ‘Save As’ 
dialog box.

Close the Document: Close the current document by selecting File→Close command on 
the menu bar or click the Close icon if it is visible on the Standard toolbar.

Printing a Document 
To print a document or selected pages follow the steps given below: 

1.  Open the document to be printed. 
2. Choose File → Print command on the menu bar. 

The Print dialog box will open. Select the Options like print range, Number of copies, Printer 
name etc. See that printer is switched on and the paper is available in the printer tray. 

3. Click OK.

Print Preview: Print preview provides a way to see how your document will look when 
printed. You can see several pages at once. It is similar to Print Layout View. An advantage 
of Print preview is that it has its own toolbar. 

▪▪ The toolbar allows you to easily view multiple pages and change the magnification 
of the screen. You can also edit your document in print preview mode. 

To switch to print preview, use one of these methods: 
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▪▪ Click on the Print preview in the file menu.  Or Press CTRL+Shift+ O keys. 

Exit Text Document: When finished you can close all the files, and quite the Word pro-
gram by selecting File→Exit command on the File menu bar.

Selecting Text
▪▪ Even though the document is built up by typing one character at a time, while edit-
ing and formatting one always work with words, lines, paragraphs and sometimes 
with the whole document. 

▪▪ For this purpose one should learn how to select the text. Once the text is selected, 
change can be made to that text. The text can be moved, copied and made as bold. 
The font and colour of the text can also be changed. For selecting text, the mouse or 
the keyboard can be used.

Selecting Text with Mouse 
Here, the following steps are to be followed. 

1. Insertion point is moved to the start of the text to be selected. 
2. The left mouse button should be clicked, held down and dragged across the text to be 
selected.
3. When the intended text is selected, the mouse button should be released.

Selecting Text with Keyboard 
The following are the steps to be followed here. 

1. Insertion point is moved to the start of the text to be selected.
2. Th e Shift  key is pressed down and the movement keys are used to highlight the 
required text. 
3. When the Shift  key is released, the text is selected.

Cut and Copy: The main difference between Cut and Copy is that cut removes the selected 
data from its original position while copy creates a duplicate of the original content.

Moving the Text: The selected text can be easily cut and pasted in the required location. 
Following steps are to be followed. 

1. Th e text to be moved to a new location is selected. 
2. Edit → Cut is selected or in the tool bar is selected to cut the selected text.
3. Insertion point is moved to the place where the text is to be pasted.
4.  Edit → Paste is selected or in the tool bar is selected to paste the text in the new 
location. 
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The text can also be pasted in this way to another or another type of document. The following 
keyboard shortcuts can be used to move text. Ctrl + X → to Cut Ctrl + V → to Paste

Copying the Text 
1. The text to be copied is selected. 
2. Edit → Copy is selected or is clicked. 
3. Th e insertion point is selected where the copy of the text should appear and is clicked. 
Th e following keyboard shortcuts can also be used for copy and paste: Ctrl + C → to 
Copy Ctrl + V → to Paste

Formatting Options
▪▪ Almost all the formatting options are available under Format menu. Libre Office 
Writer also conveniently provides buttons for the most commonly used options. 
But before these options can be used, the text on which they are to be used has to be 
selected. Once the desired portion of the text is selected then depending on the need 
any one of the following buttons are clicked:

▪▪ Click B to make text Bold. Click I to make text Italic. Click U to make text Under-
lined. Th e same can also be achieved by clicking on Format → Character Alterna-
tively Ctrl + B, Ctrl+I and Ctrl+U keys can be used to make the selected text bold, 
italic and underlined respectively. 

Changing the Fonts
▪▪ A font is a set of characters and numbers in a certain style. Each font looks diff erent 
from other fonts. Click the down arrow in the Fonts Combo box of font tab in Char-
acter dialog box. Use Format → Character to open the Character dialog box.

▪▪ From the list of available fonts, click the required one. The text changes to the se-
lected font.

▪▪ Font Size The size of the text is also important. The same size of the text cannot be 
used for a legal document, and an advertisement material. Click the down arrow 
in the Size combo box of Fonts tab in Character dialog box. The text changes to the 
selected font size.

Changing the Font Colour 
A different colour for selected text can be used. Colour printers are becoming more and more 
popular. With the help of a colour printer, some splash can be added to the documents by 
changing the colour of text. 
To use a different text color, select the text and click the arrow in the Font Colour icon A 
colour palette is displayed from which the required colour can be selected. Alternatively, 
select the text and click on the Font color icon, to apply the current colour of the Font Colour.
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 Alignment Paragraph 

▪▪ Alignment Paragraph alignment refers to the appearance of the left and right sides 
of the paragraph. By default, Word aligns paragraphs to the left. You can align para-
graphs in Word so the right sides are symmetrical. This is called right alignment. 

▪▪ You can also align them so you center the lines with even space on both sides. This 
is called center alignment. 

▪▪ Finally, you can justify the alignment, which aligns both the left and right sides. 
Four types of alignment can be selected, and the best way to make a change is to use 
the Formatting toolbar. 

The following steps are used here: 
• To change the alignment of one paragraph, first click within that paragraph. 
• To change the alignment of several paragraphs, select the ones needing change.

Page Orientation 
▪▪ Changing Page Orientation Usually the length of a document will be more than the 
width. This orientation is called portrait. But in some of the documents the width 
will be more than the length. This type of orientation is called landscape. The de-
fault orientation is portrait. 

To change the orientation or paper size, the following steps are used: 
▪▪ The Format  Page option is clicked. Click the Page tab, if necessary.
▪▪ Select the necessary paper format from the Format drop-down list in the Page. For-
mat section. Or enter the values in the Width and Height spin boxes.

▪▪ For changing the orientation Portrait or Landscape radio buttons are used.

Changing Margins 
Using Rulers If the user is not having the exact value for the margins then the Ruler option 
on the View menu can be used to change the margins. 

Following steps are used in this method: 
• If the ruler is not displayed in the screen, View → Ruler option is clicked. 
• The gray area of the ruler indicates the margin’s top area. 
• The mouse pointer is then moved in between the gray and white area of the ruler. 
• When the pointer is in the right spot, it changes into a line with arrows on both sides 
• The margin guide is dragged to a new location.


